Mob Spawners do not function

NoSprings's profile picture.NoSprings
On Feb 2, 2023






Skyblock Beta


1.19.51 on Xbox Series X


Default profile picture. No One




1 Follower(s). Click to follow and receive notifications.


Apologies if this is a repost (I've tried to reply to other posts about the same issue but the forum seems to dislike me).

Same issue as described in tickets 70, 114, 143, 144. Reporting here because most of those tickets are either marked as "cannot reproduce" or "invalid," because they asked for video links and none were provided.

To wit:

Confirmed on the latest version of Minecraft on Xbox Series X, as well as on on Android/Mobile version.

Problem is very inconsistent. Occasionally I will load into my island (or fly very far away, and then come back, causing that chunk to reload) and the spawners will, briefly, work. This is extraordinarily rare, however. (As in a total of "15 minutes in the last 5 days of playing.")

I have 2 video links to attempt to demo the problem. In these videos please keep the following in mind:

- The glass ceilings are not an issue (it works fine with them when it rarely works) and they were originally cobblestone.
- While the video clip shows multiple spawners grouped together, this, too, does not matter -- when they work, they work, and the problem persists even if only one spawner is present.

- The videos have been edited for length. Please use your imagination at the end and assume "nothing ever happens." Seemed better than linking an hour long video staring at the paint dry! ;)

Video #1:
Several IGS and Creeper spawners doing nothing. Video shows me removing and replacing the spawners in the hopes of "resetting them" somehow, but to no avail. (Not shown: Also tried relogging between removing and replacing, and/or storing them in a chest first. Same result.)

Video #2:
Spawners are removed and then tossed into the void, and re-generated via the menu option (since these were purchased with minecoins). Just to see if "getting new spawners to replace the duds" would work. As the video shows, it does not fix the issue.

Note, the enderman spawners don't work either, but I opted not to place them in this video on the off chance that they DID spawn one -- I'd rather not have dudes running all of the place stealing blocks. :)

Additional troubleshooting notes:

- The spawners shown consist of a pack purchased via minecoins ~2 years ago and a pack purchased a couple days ago. It also includes spawners purchased via the in-game store. (So the method of obtaining the spawners does not seem to be cause of the issue.)

- As mentioned above, this occurs regardless of the ceiling structure or the number of spawners deployed, or the distance from one spawner to another.

- The presence of another (invited) player also did not serve to trigger the spawners. (The player was within 10 blocks of them.)

- Problem persists on Android and Xbox bedrock clients. Have not had the opportunity to test on PC.


No Files


NoSprings's profile picture. NoSprings on 2-2-23 12:04 AM (edited)